Login    Iscriviti

Problema visualizzazione del sito con Internet explorer

Se hai trovato un errore segnalalo qui.
Posta qui idee e suggerimenti per migliorare Pc-Zone.
  • Autore
    Messaggio

Problema visualizzazione del sito con Internet explorer

Messaggio da leggereda giova95 » giovedì 1 novembre 2012, 12:53

Se volete saltare l'introduzione e leggere direttamente la soluzione al problema cliccate qui

Ciao a tutti, mi sono pervenute delle segnalazioni relative a un problema di visualizzazione del sito con Internet Explorer.
Sostanzialmente la parte superiore del sito, visitato con altri browser appare così:
Visualizzazione giusta
Immagine


Mentre con internet explorer alcuni riscontrano questo:
Visualizzazione sbagliata
Immagine


Come vedete c'è un errore sia nel menù sia nell'immagine di sfondo che risulta spostata.

Il sito è progettato per essere visto con le ultime versioni di ogni browser, ovviamente il browser che presenta più problemi di compatibilità è explorer.
In realtà anche se usate Chrome 10 (l'ultima versione è la 20) il sito funziona benissimo e non ci sono errori, così come negli altri browser.
Explorer invece è sempre stato una ventina di passi indietro rispetto agli altri... quindi se utilizzate IE9 vedete, quasi perfettamente, il sito, se usate l'8 no.
Questo anche per una mia scelta personale. Ritengo che nel 2012 la gente debba avere almeno un minimo di cultura informatica e sapere che bisogna sempre aggiornare i software. Della serie: "se ti ostini ad usare software vecchi arrangiati"

SOLUZIONE:
Explorer 9 ha una funzione secondo me molto inutile ma comunque c'è. Si chiama "visualizzazione compatibilità". Potete attivare/disattivarla dalle impostazioni o semplicemente dalla barra degli indirizzi.
Immagine
Se la funzione è attivata l'icona che ho cerchiato in rosso, è colorata in azzurrino (come nell'immagine). Invece nel caso in cui sia disattivata è grigia come le altre icone (lente di ingrandimento, pulsante per aggiornare...).


Per risolvere il problema basta disattivare la funzione. Per disattivarla cliccate sull'icona.
Si aggiornerà la pagina e poi potrete vedere il sito come deve essere visto.
Non chiedete chiarimenti tecnici per via privata! I problemi vanno esposti direttamente sul forum, per il bene di tutti.
Vota il forum! :-)
Avatar utente
giova95
Admin
Admin
Pc-Master
Pc-Master
 
Messaggi: 2839
Iscritto il: mercoledì 18 luglio 2012, 10:25
Località: Strona (BI)
Sistema Operativo: Windows 7
CPU: Intel Pentium T4500
RAM: 4GB DDR3
HDD: 320GB
Preassemblato:

Re: Problema visualizzazione del sito con Internet explorer

Messaggio da leggereda mrharry71 » giovedì 1 novembre 2012, 13:01

:ok!:
Immagine
Avatar utente
mrharry71
Pc-Master
Pc-Master
 
Messaggi: 2767
Iscritto il: mercoledì 18 luglio 2012, 18:28
Località: l'isola che non c'è

Re: Problema visualizzazione del sito con Internet explorer

Messaggio da leggereda Barrnet » giovedì 6 dicembre 2012, 13:15

Peccato che gli utenti di Windows Xp siano bloccati, per volere della Microsoft stessa, a Internet Explorer 8.
Avatar utente
Barrnet
 
Messaggi: 13
Iscritto il: sabato 28 luglio 2012, 20:10

Re: Problema visualizzazione del sito con Internet explorer

Messaggio da leggereda giova95 » giovedì 6 dicembre 2012, 17:57

Bene. Ti ringrazio, in realtà lo avevo già letto ma me ne ero dimenticato. Devo modificare la struttura css del menù...
Non chiedete chiarimenti tecnici per via privata! I problemi vanno esposti direttamente sul forum, per il bene di tutti.
Vota il forum! :-)
Avatar utente
giova95
Admin
Admin
Pc-Master
Pc-Master
 
Messaggi: 2839
Iscritto il: mercoledì 18 luglio 2012, 10:25
Località: Strona (BI)
Sistema Operativo: Windows 7
CPU: Intel Pentium T4500
RAM: 4GB DDR3
HDD: 320GB
Preassemblato:

Torna a Segnala bug e suggerimenti

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Torna all'indice