Pagina 1 di 1

Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: giovedì 30 agosto 2012, 9:02
da giova95
Ieri è stato segnalato un possibile bug da parte di PRS riguardante le mail ricevute dal sito quando si è sottoscritti a un argomento.
Come ben sapete, se vi sottoscrivete a un argomento ricevete delle notifiche via mail quando ci sono nuove risposte.
La mail in questione è strutturata in questo modo:
Ciao NomeUtente,

ricevi questa notifica perche' stai controllando il forum "NomeDelForum su "NomeDelSito". C'e' stata una risposta all'argomento dalla tua ultima visita.
Tramite i link seguenti puoi vedere tutte le risposte;
non riceverai altre notifiche fino alla tua prossima visita.
Se vuoi vedere la risposta piu' recente dalla tua ultima visita, clicca
sul seguente link:
LinkDirettoAll'UltimaRisposta


Per visualizzare l'argomento clicca sul seguente link:

LinkDelTopic


Per visualizzare il forum clicca sul seguente link:
LinkDelForum

Se non desideri piu' controllare questo argomento puoi cliccare su
"Annulla sottoscrizione argomento" che trovi sull'argomento sottoscritto, o
cliccando sul link seguente:

LinkPerEliminareSottoscrizione


Cliccando sul primo link, quello che ho segnato in rosso, si dovrebbe essere reindirizzati direttamente all'ultima risposta al nostro topic, ma è necessario essere loggati; in caso contrario si viene reindirizzati alla pagina di login.
Come detto da PRS è fastidioso doversi loggare tutte le volte.
Così mi sono informato... ho scoperto come risolvere questo "errore", ma ho anche capito che di "errore" non si tratta. Esattamente, avete capito, non è un errore.
È una cosa volontaria *1.

Come potete leggere nell'esempio di e-mail sopra "non riceverai altre notifiche fino alla tua prossima visita" quindi finchè non leggete la risposta non riceverete altre mail nel caso ci siano nuove risposte.
Il problema è che avere letto o meno un topic viene memorizzato nel nostro database. Nel momento in cui siete loggati e leggete la risposta, il sito registra questo fatto e lo memorizza nel database, ma solamente se siete loggati.
Se visualizzate la risposta, ma senza effettuare il login, il sito non ha la sfera di cristallo e non può capire che siete proprio voi che state leggendo, quindi non memorizza nessun dato.
Da qui la schermata di login: dopo aver cliccato sul link della mail siete invitati ad effettuare il login così il sito può registrare il fatto che avete letto la risposta e se ci saranno altre risposte vi verranno inviate altre mail.

Con l'occasione ringrazio PRS per la segnalazione e il team di phpbbitalia che mi ha aiutato a risolvere l'enigma.

Inoltre ricordo che se pensate di aver trovato qualche bug e volete segnalarlo potete utilizzare la sezione apposita: segnala un bug.

*1 Ricordo che il sito sfrutta il cms phpBB3, il pacchetto gratuito più famoso per l'utilizzo dei forum. Ovviamente è completamente personalizzabile, forse è per questo che è così famoso ed utilizzato :-)

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: giovedì 30 agosto 2012, 13:34
da Scapuc
Grande Giova, sempre perfetto! :good:

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: giovedì 30 agosto 2012, 16:55
da mrharry71
supergiova :com:

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: venerdì 31 agosto 2012, 15:46
da PRS
Risolto,risolto ,ma ancora con cantiere aperto? Lo dico perchè personalmente ritrovo lo stesso errore

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: venerdì 31 agosto 2012, 15:53
da giova95
Se leggi bene capisci che non è un errore e non ho intenzione di risolverlo, proprio perchè non è un errore.
È una cosa necessaria al buon funzionamento del sito, se la tolgo ti lamenteresti di un errore ben più grave, non riceveresti le mail.

Come vedi nel titolo "bug" è tra virgolette, perchè di bug non si tratta :)

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: venerdì 31 agosto 2012, 18:15
da PRS
Ok, non avevo letto.Leone cativo cativo... :tie:

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: venerdì 31 agosto 2012, 18:58
da giova95
:wink:

Re: Risolto "bug" dei link nelle mail

Messaggio da leggereInviato: venerdì 31 agosto 2012, 19:36
da mrharry71
:wow: :wink: