Pagina 1 di 1

Problema visualizzazione del sito con Internet explorer

Messaggio da leggereInviato: giovedì 1 novembre 2012, 12:53
da giova95
Se volete saltare l'introduzione e leggere direttamente la soluzione al problema cliccate qui

Ciao a tutti, mi sono pervenute delle segnalazioni relative a un problema di visualizzazione del sito con Internet Explorer.
Sostanzialmente la parte superiore del sito, visitato con altri browser appare così:
Visualizzazione giusta
Immagine


Mentre con internet explorer alcuni riscontrano questo:
Visualizzazione sbagliata
Immagine


Come vedete c'è un errore sia nel menù sia nell'immagine di sfondo che risulta spostata.

Il sito è progettato per essere visto con le ultime versioni di ogni browser, ovviamente il browser che presenta più problemi di compatibilità è explorer.
In realtà anche se usate Chrome 10 (l'ultima versione è la 20) il sito funziona benissimo e non ci sono errori, così come negli altri browser.
Explorer invece è sempre stato una ventina di passi indietro rispetto agli altri... quindi se utilizzate IE9 vedete, quasi perfettamente, il sito, se usate l'8 no.
Questo anche per una mia scelta personale. Ritengo che nel 2012 la gente debba avere almeno un minimo di cultura informatica e sapere che bisogna sempre aggiornare i software. Della serie: "se ti ostini ad usare software vecchi arrangiati"

SOLUZIONE:
Explorer 9 ha una funzione secondo me molto inutile ma comunque c'è. Si chiama "visualizzazione compatibilità". Potete attivare/disattivarla dalle impostazioni o semplicemente dalla barra degli indirizzi.
Immagine
Se la funzione è attivata l'icona che ho cerchiato in rosso, è colorata in azzurrino (come nell'immagine). Invece nel caso in cui sia disattivata è grigia come le altre icone (lente di ingrandimento, pulsante per aggiornare...).


Per risolvere il problema basta disattivare la funzione. Per disattivarla cliccate sull'icona.
Si aggiornerà la pagina e poi potrete vedere il sito come deve essere visto.

Re: Problema visualizzazione del sito con Internet explorer

Messaggio da leggereInviato: giovedì 1 novembre 2012, 13:01
da mrharry71
:ok!:

Re: Problema visualizzazione del sito con Internet explorer

Messaggio da leggereInviato: giovedì 6 dicembre 2012, 13:15
da Barrnet
Peccato che gli utenti di Windows Xp siano bloccati, per volere della Microsoft stessa, a Internet Explorer 8.

Re: Problema visualizzazione del sito con Internet explorer

Messaggio da leggereInviato: giovedì 6 dicembre 2012, 17:57
da giova95
Bene. Ti ringrazio, in realtà lo avevo già letto ma me ne ero dimenticato. Devo modificare la struttura css del menù...